About Me

Wednesday, October 19, 2011

MasterClass - New Maya cmds compatible version

After a number of requests I've gone through the MasterClass toolkit and made it backward compatible with Maya 2008 onwards (actually I've only run it back to 2009 but should still work on 2008). This is kind of tested but if you get any issues let me know and I'll fix them. Basically all I've done is to remove the PyMel calls and replace them with cmds, also made it Python 2.5 compliant.

Anyway, here's the link to the new AnimationBinderCmds.py module file. Install is easy, like the main class all you do is drop it into the Maya scripts folder, or any folder on the Maya scripts path, then in a Python Tab type: (with no tabs or spaces at the front of each line)

import AnimationBinderCmds as AB
AB.AnimBinderUI.Show()

Here's the link:


AnimationBinderCmds.py


Thanks for the interest

Mark